Error on Updating Hosted Sites - site_default does not exist (SOLVED)

I usually find the update process a bit sticky (not being able to use the drupal update system), but have never had errors.
On this new 2.1.3 update I got the following error.
Yes it says HTTP 200, but it’s an error :slightly_smiling_face:

I extracted the new package tarball, overwrote everything except web/sites and then tried to run the update.php script. This occurs immediately on that step.

Anything I did wrong? I could be an idiot. Extremely possible.

I have restored db and files to last night’s backup.
Downloaded latest, unpacked, overwrote all but web/sites/ and attemped update.php again:

Drupal\Component\Plugin\Exception\PluginNotFoundException: The "site_default" plugin does not exist. Valid plugin IDs for Drupal\charts\ChartManager are: chartjs, google in Drupal\Core\Plugin\DefaultPluginManager->doGetDefinition() (line 53 of core/lib/Drupal/Component/Plugin/Discovery/DiscoveryTrait.php).```

Definitely something deeper than I can comprehend

@marlonv: The root cause of this issue seems to be related to the Charts module, which is not included with farmOS. Did you add that yourself?

It may be that the module was not configured properly, and now that causes updates to fail. If you are not using the module, try uninstalling it first, and then see if you’re able to update.

1 Like

Thanks Mike
I will keep looking for the issue. I did not install charts, so I have no idea why it is moaning about the site_default for that

farmos@goatbox:~/public_html$ composer show | grep chart
farmos@goatbox:~/public_html$ composer show | grep charts

Nada :confused:

1 Like

In the end, I had to remove charts and all related things.
It was installed as deps for ‘animal_weight’ module, and sadly I had to remove that too.
This solved this issue and I could run update.php and get to latest farmOS, alas, without animal_weight
Hope this thread helps anyone else who may encounter this trout in the face.
Thanks for the replies @mstenta - appreciated

1 Like

Ah! OK we should open a bug report in that module’s issue queue and follow up there. Thanks for reporting it @marlonv!

@paul121 and I are maintainers of that module, but it hasn’t seen much action recently (and there’s never been a stable release for it yet). Would love to see it get polished up a bit! If anyone wants to help, it would be welcome!

1 Like