An AJAX HTTP error occurred. farmos2 beta1

I just started to install the farmos 2 version beta 1 on a raspberry pi, I followed the installation steps at the end I get the following message:

An AJAX HTTP error occurred.
HTTP Result Code: 500
Debugging information follows.
Path: /farmos/web/core/install.php?profile=farm&langcode=en&continue=1&id=2&op=do_nojs&op=do
StatusText: Internal Server Error

1 Like

Hi @mzghoumi - Are you using Docker or a packaged release tarball? If tarball, what version of PHP are you using?

Your Apache server logs will give you more information about the 500 error. Can you paste the error message here?

Hi @mstenta, i am using a packaged release tarball.

I resolved the issue due to a mistake in my apache configuration file to support Server configuration for Clean URLS by adding
<Directory “/var/www/html”>
AllowOverride All


Glad you figured it out @mzghoumi !

I have the same issue. Unfortunately, I use a hosted web server and don’t have access to /var nor the Apache configuration. Is there another solution for the above mentioned problem?

1 Like

@Farmy Does your host provide any access to server logs? I would think most do in some form.

@mstenta Yes, I think so. What do you want to see? Does this one help?

mod_fcgid: stderr: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/vhosts/ on line 1033, referer:


Yes it does! It looks like it’s taking longer to do something than your host allows.

farmOS recommends a minimum PHP max_execution_time setting of 240.

See Installing farmOS | farmOS for that and other PHP config recommendations.

1 Like

Thanks for your hint! The host admin set the limit temporarely to 300s. Then the installation worked like a charm. :slight_smile: Thanks again for your help.