farmOS 2.0.0 has been released! Happy New Year! 🎉

farmOS 2.0.0 has been released!

This is a significant milestone for the farmOS community. It is the first “stable” release of the farmOS v2 branch.

For more information, read the blog post:

For the full release notes, see

Happy New Year! :smiley:


Thanks Mike for this. I have done the update but seem to have lost all my formatting. I was updating from beta 4 to the latest stable version. I did the upgrade.php and all seemed fine. Initially when I was able to log into the site I cleared the cache but it appears the same in a private browser.

Any ideas what I have done wrong ?! I am using php 8.1

1 Like

Hmm - did you clear caches through the UI, or via CLI drush cr? Might be worth trying drush cr if you haven’t already.

Looking at the Log there are several errors similar to " The specified file ‘temporary://filelYnumT’ could not be copied because the destination directory ‘public://js’ is not properly configured. This may be caused by a problem with file or directory permissions."

It looks like my permissions are not set up correctly - what permissions should I set to allow it to work and should I set them before the upgrade ?

Thank you - FarmOS has become an essential part of how I record all of our work here !

Oh yea that would explain it. Strange that it worked before you upgraded though. :thinking:

This describes the basics:

Are you using the Docker-based or tarball-based install described here? Installing farmOS | farmOS

Generally, your files directories will be in:

  • web/sites/default/files (public files)
  • web/sites/default/private (private files)

Both need to be writable by the web server. In the farmOS Docker image, that is the www-data user. But if you are doing something different (like hosting on Nginx) then it will be something different.

I generally just chown both of them to www-data:www-data, but as long as they’re writable by www-data it should work.

Here’s a whole bunch of info on the security considerations:

Hope that helps!

HI Mike,

Just reaching out again as I have still not managed to move on from Beta 4 !

I have tried all of the above ideas, checked that the folders are writable and tried most over the versions more recent than beta 4 but all do exactly the same result that all formatting is lost as per the first image of the site.

The only other thing I have worked out is the formatting is fine when I have uploaded the new files it is only the process of the upgrade that forces some change to lose all the formatting.

I have now set up a Dev site so I can continue to use my real site until I work out the issue

The update process I do is as follows 1. take backup of files and database 2. delete and recreate new database 3. Delete old Files 4. Upload release and deploy files 5. Delete Sites Folder 6. Deploy old Sites files and update settings (not default_settings) with the new database password 7. go to update.php and follow online instructions.

In my sites folder I have a default_settings and settings.php files. I only update the settings one - is this correct ?

If there is anything else you can suggest / help with to get me up to date it would be really appreciated.


Hi @oliverp44! Maybe it would be easier to debug this together sometime. We host a weekly dev call on Thursdays at 12 noon Eastern (just missed this week’s!)

We also have a chat room that could work for debugging this together:

In the meantime…

Are you following the official upgrade instructions from this page?

You shouldn’t “delete and recreate a new database”. Upgrades do not need to touch the database at all (and if they do, that is automated via update.php).

And are you using Docker or are you using the “packaged release” as described on Installing farmOS | farmOS?

If you are using the “packaged release”, the best way to do it is to MOVE your web/sites directory somewhere safe (eg: up two or three directories so it is completely outside of the farmOS codebase), then delete EVERYTHING in your webroot (including vendor, web, and everything else that comes with the packaged release). Then, delete the new web/sites directory and move your sites directory back into the new web directory.

The sites directory contains all the stuff you want to preserve, like your settings.php file (which tells Drupal how to connect to the database), and all your uploaded files.

I bet following those steps will lead to a successful upgrade. It sounds like you may have been deleting too much… :slight_smile:

If not, hop into chat sometime and let’s figure it out!

Thank you - sorry I rushed my post !

I am using packaged release and should not have included the bit about deleting the database (I am having to do that to reset it back to the working version so not relevant for the upgrade. I have done the upgrade process again following your steps with the same result.

I think it is a permissions issue as the CSS does not work - in the source file the css stylesheet paths are

link rel=“stylesheet” media=“all” href=“/Dev/farmOS/web/” />
link rel=“stylesheet” media=“all” href=“/Dev/farmOS/web/” />
link rel=“stylesheet” media=“all” href=“/Dev/farmOS/web/” />"

So not a proper stylesheet path.

I think it must be file / folder permissions for the server or something but not sure.

A chat would be great at some stage when you have time ?



1 Like

@oliverp44 Feel free to join the chat if you want to debug together:

Or, if you can join the dev call this Thursday at 12pm Eastern, we can screenshare and get it sorted. Jitsi Meet

Thank you - when do you think we could do the chat ?

Hop in whenever you want! If I’m there, I’ll help - otherwise someone else might, or I will respond when I can. We can do it semi-syncronously. :slight_smile:

Thanks Mike,

I will plan to join the dev call tomorrow which I think is 5.00pm UK time. I assume I don’t need to do anything else except joint the meeting ?



Great! See you there! :slight_smile:

I am still struggling to upgrade my version of FarmOS as we previously discussed. Seems to be a folder permissions issue as the upgrade seems to work fine but it loses all css formatting. I am using packaged version.

I have struggled with this for quite some time and think I need to get some external help otherwise I am going to be left in the ark ages !

Would there be anyone on the community who could help with the upgrade to get me up and running with the latest versions.

1 Like

Hi @oliverp44 - sorry to hear you’re still having trouble. Would you be able to join a dev call sometime to look at it together? We also have a chat room where we might be able to work through it live. Although the dev call is probably more of a guarantee that someone will be online.

1 Like

Thanks - I will certainly join a Dev call. I was just concerned that last time the amount of time it took up of the call. Can you remind me when they are ?


That’s OK @oliverp44 - the calls vary - sometimes there is time available and sometimes there isn’t. But that’s probably the best place to get live help with this. I don’t remember where we got to last time we tried, and I can’t guarantee we’ll get much farther, but worth a shot!

The calls are at 12 pm noon Eastern time on Thursdays (today) here: Jitsi Meet