The website encountered an unexpected error. Please try again later

On installing modules it show this error page.

I’m running into a similar error right after a fresh install of farmos2.x. I enabled verbose logging by updating /sites/default/settings.php, adding this line:

$config['system.logging']['error_level'] = 'verbose';

Now this is the message I’m seeing on the home page:

The website encountered an unexpected error. Please try again later.

Symfony\Component\HttpKernel\Exception\NotFoundHttpException: No route found for "GET /" (from "http://<my-domain>/core/install.php?profile=farm") in Symfony\Component\HttpKernel\EventListener\RouterListener->onKernelRequest() (line 136 of /opt/drupal/vendor/symfony/http-kernel/EventListener/RouterListener.php).
Drupal\Core\Routing\AccessAwareRouter->matchRequest(Object) (Line: 112)
Symfony\Component\HttpKernel\EventListener\RouterListener->onKernelRequest(Object, 'kernel.request', Object)
call_user_func(Array, Object, 'kernel.request', Object) (Line: 142)
Drupal\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch(Object, 'kernel.request') (Line: 134)
Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object, 1) (Line: 80)
Symfony\Component\HttpKernel\HttpKernel->handle(Object, 1, 1) (Line: 57)
Drupal\Core\StackMiddleware\Session->handle(Object, 1, 1) (Line: 47)
Drupal\Core\StackMiddleware\KernelPreHandle->handle(Object, 1, 1) (Line: 47)
Drupal\Core\StackMiddleware\ReverseProxyMiddleware->handle(Object, 1, 1) (Line: 52)
Drupal\Core\StackMiddleware\NegotiationMiddleware->handle(Object, 1, 1) (Line: 23)
Stack\StackedHttpKernel->handle(Object, 1, 1) (Line: 706)
Drupal\Core\DrupalKernel->handle(Object) (Line: 19)

Could we be facing the same error?

@raheel Does this relate at all to the other forum topic you posted?

It would be easier if you just create a single topic and we work through your deployment issues one at a time. Your other topic suggests that you never got farmOS running, but in this one you said you tried to install a module, so I’m confused as to where you actually are in the process.

@gmagnusson I doubt this is the same issue you are encountering. I would suggest you create a dedicated topic as well and we can debug separately.

Alternatively, you are both welcome to join the farmOS chat room: - If we are both online at the same time I may be able to help debug little issues like this.

First i encountered this when the farmOS was installing the module i selected in the installation process, i thought the issue is with docker container maybe it got corrupted or something, so i tried to redeploy it through docker, at that time i faced the {“Apache/2.4.38 (Debian) Server at localhost Port 80”} this one.

1 Like