Become a beta tester for farmOS Field Kit on iOS (et al)

Apple has made it a little easier now to become a beta tester for the farmOS Field Kit iOS app. Now all you have to do is go to this link and follow the instructions to install Test Flight, if you haven’t already, then Field Kit:

If you’re on Android, you can install the beta version here: https://play.google.com/store/apps/details?id=org.farmos.app

One more way you can try it out, is with the Field Kit progressive web app (PWA), which you can find at https://farmos.app.

It’s still not fully stable, but getting more so by the day. If you have a chance to let us know what you think, post back here at the forum to document your experience.

1 Like

Despite some hiccups getting started (per this msg thread just concluded), i can now say with some confidence: come on in, the water’s fine!

Guess i should qualify that statement by saying: i’m on iOS, can’t verify that both the Field Kit mobile app and PWA version are working perfectly on Android (though a colleague of mine did a quick test of FieldKit on 'droid, and it appeared to launch and sync w/o trouble), our instance is hosted at Farmier (farmos.net), and it’s very early days for us, so i can’t say my testing has been comprehensive as of yet.

Still: if like me, you are motivated to have mobile access to farmOS (for me, it’s a mandatory requirement), then i hope you will join us in testing, so together we can ensure this thing is bulletproof in all our various use-cases.

1 Like

Thanks, @walt, and thanks too for helping to document some of those early hiccups! :wink:

I am excited to try this out! I have an old computer, wifi network, an old iPad, and some land I need to take notes on.

2 Likes

Glad to hear it @scissors, let us know if you experience any trouble!

1 Like

Hi, i cannot Login to my farmos server with field kit. I always get
“Unable to reach the server. Please check that you have the correct URL and that your device has a network connection. Status: Request failed with status code 403”
I’m pretty sure that URL, user and password are correct as I’m using a password manager.
Trying Android or Webapp of Field Kit lead to same results.
I’m using version 0.4.9
I’m running farmos in a docker and use traefik as a reverse proxy.
My URL is like farmos.mydomain.de if that’s relevant.
Can someone help me find out what’s the issue?

Hi @PDorfFarm, sorry you’re having difficulty. @mstenta, do you know if the reverse proxy could be a factor here? I don’t believe this is a CORS error, if it’s giving a 403.

Hmm - did you get SSL working @PDorfFarm? And is it a valid certificate (not self-signed)? I think that’s a requirement for Field Kit to be able to connect.

Hello,
Would someone be able to tell me how I can get an invitation email or find the public link for using the farmOS Field Kit app on an iOS system? I’ve downloaded TestFlight but am unsure of what the next move is.

1 Like

Hi @Johnny,

Once you have Test Flight installed, you should be able to install the app by reopening that same link from your phone: https://testflight.apple.com/join/A35xRBwE

Here are the official instructions from Apple:

Installing a Beta iOS App from an Email or Public Link Invitation

  1. Install TestFlight on the iOS device that you’ll use for testing.
  2. Open your invitation email or tap on the public link on your iOS device.
  3. Tap View in TestFlight or Start Testing; or tap Install or Update for the app you want to test.

I’m at a disadvantage because I don’t have an iPhone to test it out on myself, but I assume that once you have Test Flight installed, it will open that link in the Test Flight app rather than the browser, allowing you to install it.

1 Like

This worked! Thank you!

2 Likes

Yes, I have SSL working. I’m using traefik with an letsencrypt certificate - not self-signed. I was not yet able to see any hints in the logs. The docker container log just tells me about an access of the website:

172.18.X.X - - [20/Dec/2019:22:42:41 +0000] "POST /user/login HTTP/1.1" 302 544 "https://farmos.app/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0"

Error message is identical if I use the Android app or the web app “farmos.app”.

Hi @PDorfFarm, thanks for the extra info. I’m not sure, but I’d still have to guess it’s got something to do with traefik, maybe specifically with the redirects that are a part of the authentication process. I’ll have to confer with @mstenta since he’s the expert on server issues (I may be totally off the mark). We’ll try to get back to you soon, but with the holidays fast approaching, it might be a little while before we can give this the proper attention. In the meantime, could you open an issue on https://github.com/farmOS/farmOS-client/issues? I think this is a bug that might have to do with your specific server configuration, and it would probably be best if we track it as an issue there so that it gets flagged as a bug that we can triage, and so that it’s documented for later users who may encounter the same issue.

1 Like

I agree with @jgaehring - let’s spin this off as a bug report and continue debugging on GitHub.

We’ll get to the bottom of it. Happy Holidays @PDorfFarm!

@PDorfFarm I had a similar issue not being able to log into my farmOS server with field kit app. I resolved this by making sure I was logged out in all other locations. I was logged in on my computer, phone, and tablet. once I was logged out in the other places the field kit was able to log in, then I was able to log in elsewhere again.

1 Like

I was logged in on my computer, phone, and tablet. once I was logged out in the other places the field kit was able to log in, then I was able to log in elsewhere again.

Ah yes! This is a known issue… but it only happens when you are using the Field Kit web app https://farmOS.app - not the Android/iOS apps (as far as I know). Thanks for mentioning this @BOTLFarm.

The reason for this is because Field Kit is currently authenticating with farmOS by sending a POST request to /user/login. But if you are already logged in (eg: in your full farmOS system in another tab), then that path will not work. FWIW this will be fixed when we move to using OAuth for authentication (soon!)

Is that what’s happening to you @PDorfFarm? Or are you experiencing this issue in the Android/iOS apps?

For clarification, This was happening to me with both the web app and the Android app.

1 Like

@BOTLFarm - hmm well that is perplexing. AFAIK the cookie issue shouldn’t affect the Android app. Unless Cordova shares cookies with the phone browser? Maybe it does, actually. @jgaehring do you know?

Hi, sorry for not responding recently.
I tried to log off with all other devices as suggested by @BOTLFarm but the error still persists. I have described the problem in github issue #281

Thank you all for your engagement. I hope we can fix that. Let me know if I can provide further tests or log files or anything else.
I also wish you all happy holidays. Enjoy and take a rest!

1 Like

My iPad is an old iPad Mini, and it will only update to version 9.3.5. Is there an older version of the testflight app I can try?

1 Like