Map location mismatch

I have some mismatch in map locations on both v1 and v2.
When I tap a field, it’s another nearby field that pops up.


1 Like

Do the two fields overlap? Perhaps the “nearby field” is actually being drawn on top of the one you are clicking? Are they the same “field type”, or different types? Different field types will render in a specific order, so that certain types generally appear under other types, so in some cases you need to “hide” the layers that are on top in order to be able to click on the ones underneath (when they overlap).

If they are not overlapping then it might be something else going on…

There’s no overlap.Space between all fields.
Land asset, field type.
Its not only the fields. Every object on the map is working strange.
Looks like its different behavior on different zoom levels.
Sometimes, depending on where I click on the field, I get different result.

If I click the lower half of one field, I get info on that field. If I click the upper half of the same field, I get many other fields listed, but not the field I was clicking.

If I zoom in one step, I get info from that field no matter where I click inside that field.

I can’t spot any editing mistakes.

1 Like

Hmm would it be possible to make some kind of screencast to show us?

The only thing I can think of: it reminds me of an old issue that would happen with Google Maps - where if you zoomed too far in, Google would stop updating their layer even though you were zoomed farther in, so you thought you were drawing in the correct place but you weren’t. Are you using Google Layers?

Yep… I’m using open streetmap

First 3 pics are from the dashboard:
I’m clicking where the popup arrow is pointing. (No field there)
The field in the popup is the field with a black star on.

Here I zoomed up one level and clicked about the same place.
Different field in the popup.

Same zoom as in 2

These pics are from Land Asset:
Zoomed out abit. Clicked the upper half of Bredesmoen field
The 2 Sannan fields in the list are the to on top of the map.

Same zoom. Clicked on the lower half of Bredesmoen field

1 Like

Wow that is weird @pat! What browser are you using? I wonder if it happens in other browsers?

I’m unable to replicate this in Firefox, but that’s the only one I’ve tested.

I’m on Firefox 95.0.1, linux. Quite strict privacy setup.
I’ll try different browsers and see what happens…

1 Like

Hah… Chromium works as expected…
Also tried Firefox in troubleshoot mode, but no luck with that.

1 Like

Oh weird! I’m using Firefox on Linux. Maybe something with your configuration? Very curious now!

With a new linux user and the same firefox it worked as expected.
I narrowed it down to firefox’s fingerprint protection.
If it’s enabled it works fine with all other settings as before.

Wow! Good sleuthing @pat! I wonder if it affects OpenLayers generally, or if it’s something specific to our farmOS-map code. :thinking:

We use the OpenLayers popup feature. Here is an example in the upstream project: Popup - I wonder if that example exhibits the same behavior?

1 Like

I think it’s FarmOS

In the poup you provided, it seems to work fine with or without fingerprint protection.

And on FarmOS it is possible to turn fingerprinting on/off
On this is missing.

Solution for me would be using chromium for FarmOS, and leave fingerprint pretection on in Firefox