Watcher not catching changes; clearing admin cache updates frontend

Hi, I just recently started playing around with FarmOS, using the Docker setup, but I am having trouble seeing changes or getting the watcher to pick up changes.

Editing www/web/themes/gin/templates/page/page.html.twig doesn’t immediately take, I need to “clear all caches”, but even then the watch still hasn’t acknowledged the change.

Any idea what could be causing this? Am I editing the wrong file location? I have checked webpack installation / config. I’m on MacOS now, but I tried with the same results on a linux machine the other day.

Thanks in advance!

Hi @nolwag - welcome to the farmOS forum! :slight_smile:

I’m not sure what you mean by “watcher”. Can you elaborate?

Generally speaking, this sounds like a Drupal theming support request more generally, not specific to farmOS. farmOS is mostly just a thin layer of farm-specific modules on top of Drupal and the Gin theme. For general Drupal questions you will have more luck asking in Drupal Slack or Drupal Answers.

Happy to provide pointers if I can, but those resources might be a better place to start, so we can focus on questions related to the farmOS-specific layers here. :slight_smile:

This might be helpful:

@nolwag it looks like you have a SASS compiler open in the terminal - you likely want to disable the CSS and JS aggregation options. This way you don’t need to disable the cache after each change. They are at the bottom of the performance page.

1 Like

@mstenta Thank you, excited to get involved.

CSS / JS watcher, I found it in the readme in the /gin directory.

Got it, sounds like I need to look in the Drupal theme development direction. Thank you!

@paul121 Correct, running from the npm cmd above. I will try that, thank you.

1 Like